Degraded performance

Incident Report for Sequence

Resolved

We've resolved the issue affecting performance.
Posted Mar 31, 2025 - 16:11 UTC

Monitoring

We've identified an issue and we're monitoring the resolution.
Posted Mar 31, 2025 - 10:52 UTC

Investigating

We're currently investigating degraded performance on the Sequence dashboard and API.
Posted Mar 31, 2025 - 08:57 UTC