Degraded performance on Sequence Dashboard and APIs

Incident Report for Sequence

Resolved

This incident has now been resolved; the Sequence Dashboard and APIs are now working as expected.
Posted Mar 20, 2025 - 09:59 UTC

Investigating

We are currently investigating an issue with failing API requests which are affecting the Sequence Dashboard.
Posted Mar 20, 2025 - 09:20 UTC
This incident affected: Sequence (API, Dashboard).