The underlying incident with our cloud provider has been resolved.
Posted Jun 13, 2025 - 08:12 UTC
Monitoring
We are seeing signs that our services are recovering. The dashboard and customer portal are now accessible but may have intermittent errors.
Posted Jun 12, 2025 - 19:33 UTC
Identified
The issue is confirmed to be an outage with our cloud provider. We will continue to monitor and update when there is a fix.
Posted Jun 12, 2025 - 18:54 UTC
Update
We believe our cloud provider is experiencing an incident which affects Sequence's availability in sandbox and production. We will monitor the situation and provide updates when we can.
Posted Jun 12, 2025 - 18:18 UTC
Investigating
We're investigating elevated latency and error rates on our sandbox and production environments
Posted Jun 12, 2025 - 18:11 UTC
This incident affected: Sequence (API, Billing, CPQ, Customer portal, Dashboard, Data exports, Third party integrations, Usage).