Dashboard crashes and third party integration issues

Incident Report for Sequence

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 17:06 UTC

Monitoring

We have identified the issue related to price editing and third party integrations and a fix is in place. The Dashboard was seeing intermittent crashes as part of price editing, and third party integrations were impacted
Posted Mar 19, 2025 - 16:19 UTC
This incident affected: Sequence (API, Dashboard).