Sequence

Degraded performance of bulk invoice recalculations
Resolved·Degraded performance

Bulk invoice recalculations are now performing as expected.

Fri, Aug 8, 2025, 02:00 PM
(3 weeks ago)
·
Affected components
Updates

Resolved

Bulk invoice recalculations are now performing as expected.

Fri, Aug 8, 2025, 02:00 PM

Monitoring

A fix was implemented last night. We're continuing to monitor

Sat, Aug 2, 2025, 11:27 AM(6 days earlier)

Identified

We have identified the issue and are implementing a fix now.

Fri, Aug 1, 2025, 04:51 PM(18 hours earlier)

Investigating

We're continuing to investigate degraded performance when bulk recalculating invoices and updating invoices.

Fri, Aug 1, 2025, 11:58 AM(4 hours earlier)

Investigating

We're investigating reports of degraded performance when bulk recalculating invoices.

Fri, Aug 1, 2025, 10:11 AM(1 hour earlier)