Billing schedules not loading

Incident Report for Sequence

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 00:15 UTC

Monitoring

The team has deployed a fix for the issue. We're now monitoring things to ensure stability with the schedules page
Posted Mar 26, 2025 - 23:08 UTC

Investigating

We're aware of an issue with Billing Schedules not loading on the schedules page currently. The engineering team is currently diving into the issue and preparing a fix
Posted Mar 26, 2025 - 22:50 UTC
This incident affected: Sequence (Dashboard).