Resolved
Salesforce is now reporting most services are back to normal however some still have degraded performance, Sequence sync is no longer showing any issues.
Identified
Salesforce is currently experiencing an outage, which is causing errors when syncing data between Sequence and Salesforce. All other parts of Sequence, including billing, invoicing and the dashboard, are unaffected. We're monitoring Salesforce's status and syncs will resume automatically once their service is restored.