Monitoring
This issue has now been resolved. We're working on a deeper resolution that should prevent this going forward.
Investigating
We're investigating an issue where a small number of Stripe-enabled invoices are being sent with a "Pay with Stripe" button that doesn't load payment options. Engineering is actively investigating. We'll update here as we have more information.