Resolved
Dropbox Sign have now resolved their degraded performance (see their status page for more info) and our team has mitigated the impact for the small number of affected quotes.
Identified
We've identified a small number of quotes are unable to be sent/signed due to degraded performance with Dropbox Sign's services.
We've reached out to the affected customers and will update here when Dropbox Sign have resolved the issue.
You can also monitor the Dropbox Sign status page here: https://status.hellosign.com/