Sequence

Third party integrations are experiencing connectivity issues.
Resolved·Degraded performance

The related AWS incident has been resolved and our third party integrations are operating as usual.

Tue, Oct 21, 2025, 09:55 AM
(1 month ago)
·
Affected components
Updates

Resolved

The related AWS incident has been resolved and our third party integrations are operating as usual.

Tue, Oct 21, 2025, 09:55 AM

Monitoring

Impact has largely resolved - we're continuing to monitor affected our third party integrations.

Mon, Oct 20, 2025, 12:55 PM(21 hours earlier)

Identified

A number of third party integrations are being affected by an ongoing AWS outage: https://health.aws.amazon.com/health/status

Our dashboard and API remain unaffected.

We'll continue to monitor and will provide further updates.

Mon, Oct 20, 2025, 10:02 AM(2 hours earlier)

Identified

A number of third party integrations are currently experiencing connectivity issues, resulting in degraded experience on Sequence.

Mon, Oct 20, 2025, 09:57 AM