Sequence

Monitoring Dropbox Sign incident
Resolved·Degraded performance

Dropbox Sign's incident has been marked as resolved

Wed, Oct 1, 2025, 07:56 PM
(2 months ago)
·
Affected components
Updates

Resolved

Dropbox Sign's incident has been marked as resolved

Wed, Oct 1, 2025, 07:56 PM

Monitoring

We're monitoring an incident with Dropbox Sign's API, which may affect the availability of e-signatures within Sequence CPQ: https://status.hellosign.com/

Wed, Oct 1, 2025, 06:08 PM(1 hour earlier)