Sequence

Increased request latencies
Resolved·Degraded performance

We've been monitoring for 24 hours and latency is back to normal

Fri, Aug 15, 2025, 08:42 AM
(3 weeks ago)
·
Affected components
Updates

Resolved

We've been monitoring for 24 hours and latency is back to normal

Fri, Aug 15, 2025, 08:42 AM

Monitoring

Latency is back to normal, we will continue to monitor today

Thu, Aug 14, 2025, 08:58 AM(23 hours earlier)

Investigating

We are currently intermittent slowness in our API and Dashboard

Thu, Aug 14, 2025, 07:29 AM(1 hour earlier)